[SciPy-dev] Weave Mandrake report.

Fernando Pérez fperez at pizero.colorado.edu
Sun Jan 13 17:13:25 CST 2002

Hi Eric,

here's a report from Mandrake again (a Mandrake 8.0 laptop with 512 Mb of ram,
and stock packages for the most part -- python updated to 2.1.1 from
Mandrake 8.1). Some system info:

[~/scipy]> uname -a
Linux maqroll 2.4.3-20mdk #1 Sun Apr 15 23:03:10 CEST 2001 i686 unknown
[~/scipy]> gcc -v
Reading specs from /usr/lib/gcc-lib/i586-mandrake-linux/2.96/specs
gcc version 2.96 20000731 (Linux-Mandrake 8.0 2.96-0.48mdk)
[~/scipy]> python
Python 2.1.1 (#1, Aug 30 2001, 17:36:05)
[GCC 2.96 20000731 (Mandrake Linux 8.1 2.96-0.61mdk)] on linux-i386
Type "copyright", "credits" or "license" for more information.

First, I tried using the updated tarballs, and failed with:

dep: ['scipy_distutils', 'scipy_test']
Traceback (most recent call last):
  File "setup.py", line 44, in ?
  File "setup.py", line 23, in stand_alone_package
    config_dict = package_config(primary,dependencies)
  File "scipy_distutils/misc_util.py", line 174, in package_config
    config.extend([get_package_config(x) for x in primary])
  File "scipy_distutils/misc_util.py", line 161, in get_package_config
    mod = __import__('setup_'+package_name)
ImportError: No module named setup_weave

Ron reported the same problem before with no answer, so I went for the cvs
files instead. It might be worth fixing this though, as I suspect a lot of
people are reluctant to use cvs.

Now, using the cvs setup, I may well be doing something wrong. I just grabbed
the whole scipy cvs tree, cd'ed into weave and tried import weave;weave.test()
after removing my .python21_* stuff and all files in ~/tmp/ related to this.

I made sure no other weave is available in sys.path to me.

I don't get the 'Abort' I was getting before anymore, so that's good news :)
But it still fails, though. Here's a summary:

First, I get the following error message a zillion times:

E/usr/local/home/fperez/.python21_compiled/44731/ext_string_and_int.cpp: In
function `FILE
*convert_to_file (PyObject *, char *)':
undeclared (first use this function)
(Each undeclared identifier
is reported only once for each function it appears in.)

This happens for many many files. I don't know how critical this particular
problem is, and what incidence it has on the later stuff.

Later, I get:

Ewarning: specified build_dir '_bad_path_' does not exist or is or is not
writable. Trying default locations
....warning: specified build_dir '_bad_path_' does not exist or is or is not
writable. Trying default locations
ERROR: result[1:-1,1:-1] = (b[1:-1,1:-1] + b[2:,1:-1] + b[:-2,1:-1]
Traceback (most recent call last):
  File "weave/tests/test_blitz_tools.py", line 153, in check_5point_avg_2d
  File "weave/tests/test_blitz_tools.py", line 127, in generic_2d
  File "weave/tests/test_blitz_tools.py", line 84, in generic_test
  File "weave/blitz_tools.py", line 99, in blitz
    type_factories = blitz_type_factories)
  File "weave/inline_tools.py", line 402, in compile_function
    verbose=verbose, **kw)
  File "weave/ext_tools.py", line 347, in compile
    verbose = verbose, **kw)
  File "weave/build_tools.py", line 176, in build_extension
    setup(name = module_name, ext_modules = [ext],verbose=verb)
  File "/usr/lib/python2.1/distutils/core.py", line 157, in setup
    raise SystemExit, "error: " + str(msg)
CompileError: error: command 'gcc' failed with exit status 1

More information about the Scipy-dev mailing list