[SciPy-dev] scipy on irix -- problems with bsplines

eric jones eric at enthought.com
Mon Jul 1 18:30:44 CDT 2002

> > I also tried building python with MIPSPro C compiler and then SciPy
> > using
> > The MIPSPro compiler suite.  The python build worked fine after
> > readline issues sorted out, and it appeared to work fine.  However,
> > python core dumped in the middle of building the flapack wrappers
> > f2py, so it looks like something is working quite right in the
> > build.  I'd like to get this working, so if anyone has built
> > SciPy/Python entirely with MIPSPro, fill me in on the secrets.
> Did you disable g77 compiler from the header
> of scipy/linalg/setup_linalg.py?
> In the latest CVS version of linalg the g77 compiler is forced only
> win32.

I hadn't, but I just tried this, and it still dies at:

Reading fortran codes...
        Reading file
        Block: cgees__user__routines
                Block: cgees_user_interface
                        Block: cselect
        Block: dgees__user__routines
                Block: dgees_user_interface
                        Block: dselect
        Block: sgees__user__routines
                Block: sgees_user_interface
                        Block: sselect
        Block: zgees__user__routines
                Block: zgees_user_interface
                        Block: zselect
        Block: flapack
                        Block: sgesv
                        Block: dgesv
                        Block: cgesv
                        Block: zgesv
                        Block: sgetrf
                        Block: dgetrf
                        Block: cgetrf
                        Block: zgetrf
                        Block: sgetrs
                        Block: dgetrs
                        Block: cgetrs
                        Block: zgetrs
                        Block: sgetri
                        Block: dgetri
                        Block: cgetri
                        Block: zgetri
                        Block: sgesdd
Bus error (core dumped)

> Another question: does your irix have ranlib? In irix64-6.5-2.1 that I
> access it is missing.

I just checked, and the machine I'm using does have ranlib.

I am using a slightly older build (from the tarballs on the site a few
days back).  I'll try again soon from the CVS and see how that goes.


More information about the Scipy-dev mailing list