[SciPy-dev] scipy on irix -- problems with bsplines

eric jones eric at enthought.com
Thu Jun 27 23:57:49 CDT 2002

SciPy builds failed in the signal module when trying to build on an SGI

Has anyone seen the following error when building something on IRIX with
gcc 2.95.2?  

25 sgi> gcc -c C_bspline_util.c
C_bspline_util.c: In function `C_IIR_order1':
C_bspline_util.c:28: Unable to access real part of complex value in a
hard register on this target
26 sgi> gcc -c  Z_bspline_util.c
27 sgi> 

It happens in several of the bspline files for complex values, but not
for double complex.  The relevant lines of code from bspline_util.c are:

21 void 
22 C_IIR_order1 (a1, a2, x, y, N, stridex, stridey) 
23     __complex__ float a1; 
24     __complex__ float a2; 
25     __complex__ float *x; 
26     __complex__ float *y; 
27     int N, stridex, stridey; 
28 { 
29     __complex__ float *yvec = y+stridey; 
30    __complex__ float *xvec = x+stridex; 
31    int n; 
33    for (n=1; n < N; n++) { 
34	*yvec = *xvec * a1 + *(yvec-stridey) * a2; 
35	yvec += stridey; 
36	xvec += stridex; 
37    } 
38 }

The only references I saw on the net were to previous problems when
building libstdc++ with 2.95.1 on SGI and ALPHA machines.

The good news is, other than this problem, SciPy builds on IRIX using
gcc and linking to the blas and scs(lapack) platform specific libraries.

I also tried building python with MIPSPro C compiler and then SciPy
The MIPSPro compiler suite.  The python build worked fine after getting
readline issues sorted out, and it appeared to work fine.  However,
python core dumped in the middle of building the flapack wrappers with
f2py, so it looks like something is working quite right in the python
build.  I'd like to get this working, so if anyone has built
SciPy/Python entirely with MIPSPro, fill me in on the secrets.


More information about the Scipy-dev mailing list