[SciPy-dev] scipy on irix -- problems with bsplines

Pearu Peterson pearu at cens.ioc.ee
Sat Jun 29 16:13:52 CDT 2002

Hi Eric,

On Thu, 27 Jun 2002, eric jones wrote:

> I also tried building python with MIPSPro C compiler and then SciPy
> using
> The MIPSPro compiler suite.  The python build worked fine after getting
> readline issues sorted out, and it appeared to work fine.  However,
> python core dumped in the middle of building the flapack wrappers with
> f2py, so it looks like something is working quite right in the python
> build.  I'd like to get this working, so if anyone has built
> SciPy/Python entirely with MIPSPro, fill me in on the secrets.

I have build SciPy entirely with MIPSPro compilers. Here follows my setup:

Python 2.1.1 (#1, Oct 21 2001, 16:10:39) [C] on irix646
Numeric 20.2.1
$ cc -version 
MIPSpro Compilers: Version 7.30
$ f77 -version
MIPSpro Compilers: Version 7.30
No ATLAS. LAPACK (3.3.14) and BLAS are built from their source (the latest
SciPy in CVS supports this feature).

My guess is that the secret you are looking for is to remove forcing g77
in scipy/setup.py file.

All tests (level=10) pass except weave tests. Typical error messages from
weave tests are: 

cc-1132 cc: ERROR File = /usr/include/CC/istream, Line = 43
  The class "std::char_traits<char>" has no member "off_type".

    typedef typename _Traits::off_type off_type;
          detected during instantiation of class
                    "std::basic_istream<char, std::char_traits<char>>" at
line 92 of "/usr/include/CC/strstream"

cc-1079 cc: ERROR File = /usr/include/CC/strstream, Line = 136
  A type specifier is expected.

    typedef char_traits<char>::off_type off_type;


More information about the Scipy-dev mailing list