[SciPy-dev] problem: xplt.imagesc from wxPython

Kasper Souren Kasper.Souren at ircam.fr
Tue Apr 22 16:18:29 CDT 2003


I decided to start trying some stuff with wxPython. And I really like it. And 
because chaco can't handle imagesc'es yet, I wanted to do them with 
scipy.xplt. But this is what I got:

Traceback (most recent call last):
  File "./wxStructures.py", line 27, in OnSelChanged
  File "/usr/lib/python2.2/site-packages/scipy_base/ppimport.py", line 211, in 
    module = self._ppimport_importer()
  File "/usr/lib/python2.2/site-packages/scipy_base/ppimport.py", line 190, in 
    module = __import__(name,None,None,['*'])
  File "/usr/lib/python2.2/site-packages/scipy/xplt/__init__.py", line 47, in 
    from Mplot import *
  File "/usr/lib/python2.2/site-packages/scipy/xplt/Mplot.py", line 46, in ?
    _user_path = _getdir()
  File "/usr/lib/python2.2/site-packages/scipy/xplt/Mplot.py", line 41, in 
    if not weave.catalog.is_writable(path):
  File "/usr/lib/python2.2/site-packages/scipy_base/ppimport.py", line 212, in 
    return getattr(module, name)
AttributeError: 'module' object has no attribute 'catalog'

Then I tried to localize the problem and I ran into another issue that's 
probably related to the one above: the imagesc window pops up, but nothing is 
shown inside. The little script can be found at [1].


[1] http://www.ircam.fr/equipes/analyse-synthese/souren/python/wxTest.py

More information about the Scipy-dev mailing list