[SciPy-dev] problem: xplt.imagesc from wxPython

Kasper Souren Kasper.Souren at ircam.fr
Tue Apr 22 18:28:09 CDT 2003

> When I ran the script [1] from a python prompt or using 'python -i' then
> a huge button pops up with label "do imagesc thingy!". Pressing it opens
> another window that is blank. When I close the button window, the
> "imagesc thingy" is finally displayed.
> Considering the above behaviour I don't think that the two problems are
> related.

You are right.

> Could you provide a simple example that demonstrates only the first
> problem?
> Also try importing weave *before* importing scipy. This will
> avoid ppimport hooks for weave and might solve the first problem.

This was sufficient to get a window popped up!

I had tried adding "from scipy import *" to the wx-stuff, but I had it placed 
after "from wxPython.wx import *". (I don't actually need scipy in the wx 
stuff, since all that is happening in other .py files.) Placing it before the 
wx import line fixed the problem.

When trying a "from weave import *" instead it doesn't work though.

But now I do get the pygist window, but it doesn't draw the stuff. So that's 
the second problem. How could I solve this?


More information about the Scipy-dev mailing list