[SciPy-dev] Problems with freetype (CVS).

Prabhu Ramachandran prabhu at aero.iitm.ernet.in
Tue Apr 29 02:31:47 CDT 2003


I just updated my CVS checkout and rebuilt scipy.  I have checked out
the newer scipy module.  The build first stopped with kiva not
compiling since agg2 would not update automatically.  So I simply did:

 cd Lib_chaco/
 cvs -q co agg2

and then kiva and everything else built fine.  After this I installed
scipy and for testing, tried running the chaco demos.  I ran into this
problem with freetype.

$ python -c "import freetype"
Traceback (most recent call last):
  File "<string>", line 1, in ?
  File "/usr/local/lib/python2.2/site-packages/freetype/__init__.py", line 5, in ?
    from freetype import FreeType
  File "/usr/local/lib/python2.2/site-packages/freetype/freetype.py", line 10, in ?
    from font_lookup import default_font_info
  File "/usr/local/lib/python2.2/site-packages/freetype/font_lookup.py", line 151, in ?
    default_font_info = FontLookup( font_dir )
  File "/usr/local/lib/python2.2/site-packages/freetype/font_lookup.py", line 30, in __init__
    self.library   = Library()
  File "/usr/local/lib/python2.2/site-packages/freetype/library_shadow.py", line 30, in __init__
AttributeError: 'module' object has no attribute 'library__create'
Exception exceptions.AttributeError: "Library instance has no attribute 'this_own'" in <bound method Library.__del__ of <freetype.library_shadow.Library instance at 0x814b3bc>> ignored

I removed the installed directory, reinstalled, deleted the build
directory, rebuilt all of scipy all to no avail.  _ft.so simply does
not have library__create().

BTW, scipy.test runs fine.

Is there a problem or am I doing something wrong?


More information about the Scipy-dev mailing list