[SciPy-dev] Cygwin build

Travis N. Vaught travis at enthought.com
Fri Mar 28 13:09:22 CST 2003

Is anyone getting a build on cygwin to work.from the nightly build:

SciPyTest  INFO  - Building:    scipy
SciPyTest  INFO  -     Version:     cvs
SciPyTest  INFO  -     Url:

    cvs:pserver:anonymous at scipy.org:/home/cvsroot
SciPyTest  INFO  -     Install dir: /cygdrive/c/temp/cygtmp/2.2-1
SciPyTest  INFO  -     Package dir: /cygdrive/c/temp/cygtmp/2.2-1/scipy
SciPyTest  INFO  -     Suffix:      tgz
SciPyTest  INFO  -     Build type:  setup
SciPyTest  INFO  - Begin Get Source: scipy
SciPyTest  INFO  - Finished Get Source: scipy
SciPyTest  INFO  - installing w/
    into /cygdrive/c/temp/cygtmp/2.2-1/lib/python2.2/site-packages
SciPyTest  ERROR - Command /cygdrive/c/temp/cygtmp/2.2-1/bin/python.exe

    setup.py  install Failed (status = 256)
Traceback (most recent call last):
  File "setup.py", line 111, in ?
  File "setup.py", line 90, in setup_package
    config_list += map(get_separate_package_config,separate_packages)
  File "setup.py", line 74, in get_separate_package_config
    return get_package_config(name,'')
  File "setup.py", line 67, in get_package_config
    mod = __import__('setup_'+os.path.basename(name))
ImportError: No module named setup_gui_thread
             [tnv] hmmmm.......
SciPyTest  ERROR - Build failed
Traceback (most recent call last):
  File "scipytest.py", line 352, in doScipyBuild
  File "autotest.py", line 676, in install
  File "autotest.py", line 642, in build
  File "stdpkgtest.py", line 427, in pythonSetup
    self.runCommand( '%s setup.py %s install' %
  File "autotest.py", line 258, in runCommand
    raise ValueError, 'cmd = %s, status = %d' % ( cmd, status )
ValueError: cmd = /cygdrive/c/temp/cygtmp/2.2-1/bin/python.exe setup.py

    install, status = 256

Travis N. Vaught
Enthought, Inc.

More information about the Scipy-dev mailing list