[SciPy-dev] CVS scipy.test() segfaulting on me on a Fedora2 box

Brett Olivier bgoli at sun.ac.za
Wed Dec 22 04:23:47 CST 2004


I've been having the same problems with gcc version 3.4.1 (Mandrakelinux 10.1 
3.4.1-4mdk). As suggested I recompiled BLAS/LAPACK with -O2 updated my ATLAS 
libs and changed gnufcompiler.py to:
	if self.get_version()<='3.4.2':
to rebuild SciPy with -O2.

However, no luck, I still get the segfault in scipy.test() with heev. Has 
anyone else tried compiling SciPy with 3.4.x compilers (I've had additional 
adventures with MinGW GCC 3.4.2 but will post these a bit later) ?


On Wednesday 22 December 2004 04:56, Fernando Perez wrote:
> Well, I'm using 3.3.3, so the code is already building with -02 only.  I
> hardcoded this change (for 3.3.3) to plain -O instead, and this thing
> segfaults all the same.  However, I did NOT rebuild ATLAS/LAPACK myself,
> I'm using those from the scipy ATLAS binaries page.
> Oh well, I'm switching to FC3 very soon, so I'll report again if the
> problem persists there.  For now it's not an issue for me, since I don't
> need those routines.  I figured I'd let you guys know about it, at least.
> Regards, and many thanks for the help,
> f
> _______________________________________________
> Scipy-dev mailing list
> Scipy-dev at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-dev

Brett G. Olivier
National Bioinformatics Network - Stellenbosch Node
Triple-J Group for Molecular Cell Physiology, Stellenbosch University
bgoli at sun dot ac dot za   http://glue.jjj.sun.ac.za/~bgoli
Tel +27-21-8082697  Fax +27-21-8085863  Mobile +27-82-7329306
There are many intelligent species in the universe, and they all own cats.

More information about the Scipy-dev mailing list