[SciPy-dev] CVS scipy.test() segfaulting on me on a Fedora2 box

Pearu Peterson pearu at scipy.org
Wed Dec 22 04:51:56 CST 2004

On Wed, 22 Dec 2004, Brett Olivier wrote:

> I've been having the same problems with gcc version 3.4.1 (Mandrakelinux 10.1
> 3.4.1-4mdk). As suggested I recompiled BLAS/LAPACK with -O2 updated my ATLAS
> libs and changed gnufcompiler.py to:
> 	if self.get_version()<='3.4.2':
> to rebuild SciPy with -O2.
> However, no luck, I still get the segfault in scipy.test() with heev. Has
> anyone else tried compiling SciPy with 3.4.x compilers (I've had additional
> adventures with MinGW GCC 3.4.2 but will post these a bit later) ?

I have gcc version 3.4.4, 3.3.5 in my debian sid box and have no trouble 
at all with scipy tests when building against these compilers. I am using 
also debian ATLAS 3.6.0 that is built against g77 3.3.3 using -O 

I'd suggest building scipy against Fortran BLAS/LAPACK libraries and see 
if the problem percist. For that, get blas and lapack sources from netlib,
unpack them, and set up the following environment for building scipy:

BLAS_SRC=<path to directory where blas.tgz was unpacked>
LAPACK_SRC=<path to directory where lapack.tgz was unpacked/LAPACK>

And in cvs/scipy/Lib/lib/lapack directory execute:
   rm -rf build
   python setup_lapack.py build

The last command could be modified also to

   python setup_lapack.py config_fc --noopt build
   python setup_lapack.py config_fc --noopt --noarch build
   python setup_lapack.py config_fc --opt="-O" build

so that you don't have to modify gnufcompiler.py and reinstall scipy_core 
all the time.

To run lapack tests without installing scipy, execute

   python tests/test_lapack.py -v 10


More information about the Scipy-dev mailing list