[SciPy-dev] bdist_rpm failure with latest scipy (and f2py) from CVS

Pearu Peterson pearu at scipy.org
Sun May 9 16:47:54 CDT 2004

On Sun, 9 May 2004, Vincent N. Virgilio wrote:

> This is my first time trying to build scipy from CVS. My platform is 
> RedHat 8.0.
> I followed the build instructions on the scipy website.
> During my attempt to package f2py, "python2.3 setup.py bdist_rpm" failed 
> at the end, complaining that some installed files were not packaged. 

Could you be more specific, e.g. send the stdout as well as stderr 
I just tried out the above command and it succeeded on Debian Sid as well
as on Red Hat 9.0. Note that f2py is pure Python package and I would
expect that bdist_rpm always works unless something is broken in the

> Fine. So I issued "python setup.py install" instead; success.

> Then I tried to package scipy. I issued "python2.3 setup.py bdist_rpm", 
> and got a similar failure as in f2py. It seems that atlas_version.so 
> gets built in "site-packages" and not "site-packages/...linalg". RPM 
> complains "installed but not packaged". No amount of fiddling with 
> setup_linalg.py or setup_atlas_version.py could change this. I am in 
> over my head.

It is ok that atlas_version.so gets built into "site-packages". Also note 
that setup_atlas_version.py is obsolete and not used anymore.


More information about the Scipy-dev mailing list