[SciPy-dev] bdist_rpm failure with latest scipy (and f2py) from CVS

Vincent N. Virgilio virgilio at ieee.org
Mon May 10 22:16:55 CDT 2004

Pearu Peterson wrote:
> On Sun, 9 May 2004, Vincent N. Virgilio wrote:
>>Then I tried to package scipy. I issued "python2.3 setup.py bdist_rpm", 
>>and got a similar failure as in f2py. It seems that atlas_version.so 
>>gets built in "site-packages" and not "site-packages/...linalg". RPM 
>>complains "installed but not packaged". No amount of fiddling with 
>>setup_linalg.py or setup_atlas_version.py could change this. I am in 
>>over my head.
>>Have others seen this error? Is there a fix?
> Try the latest CVS again. Now atlas_version.so is not installed anymore 
> while executing bdist_rpm command. Also note that in order to run 
> bdist_rpm for scipy, you have to have recent scipy_core installed in your 
> system. Otherwise you'll get 'scipy_distutils not found' errors. 
> Btw, does anybody know how to set environment for bdist_rpm? If that would 
> be possible then one does not have to install scipy_core for creating 
> rpm's for scipy.
> To summarize the steps needed for creating scipy rpm's and installing 
> them:
> 1) Create Scipy_core rpm and install it.
> 2) Create F2py rpm and install it.
> 3) Create Scipy rpm and install it.
> Note that it is not possible to create all rpm's once and then installing 
> them because latter steps require previous software installed.
> Also, before hitting bdist_rpm command, you may need to execute
>  rm -rf /var/tmp/SciPy-buildroot
> when previous bdist_rpm failed.
> HTH,
> Pearu
> _______________________________________________
> Scipy-dev mailing list
> Scipy-dev at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-dev

Thanks, that worked very well.

Vince Virgilio

More information about the Scipy-dev mailing list