[SciPy-dev] fdf package, looking for a better name

Pearu Peterson pearu at scipy.org
Wed Nov 10 03:19:30 CST 2004


- There are homeless functions in scipy such as central_diff_weights,
   derivative, pade. I am currently working on finite difference formula
   (FDF) package that will support numerical differentiation with various
   FDFs and this could become also a home for the above mentioned

   However, I have not decided yet what should be the name of such a
   package. Originally, I was using fdf. But now looking at the GAMS
   tree, that contains

    H.   Differentiation, integration
    H1.     Numerical differentiation
    H2.     Quadrature (numerical evaluation of definite integrals)
    H2c.       Service routines (e.g., compute weights and nodes for
               quadrature formulas)

   and considering that we have scipy.integrate that fits well to GAMS
   H2 class, I am thinking of renaming fdf to something else. Here are
   few choices that come into my mind:

     scipy.differentiate  (following scipy.integrate but looks longish)
     scipy.diff           (scipy_base defines diff)
     scipy.derive         (my current favorite but not completely happy)

   Any better naming suggestions?

   I would also extend GAMS tree by

    H1a. Ordinary derivatives
    H1b. Partial derivatives
    H1c. Service routines (compute weights of FDFs)
    H1d. Automatic differentiation

   that scipy should one day cover.


More information about the Scipy-dev mailing list