[SciPy-dev] gui_thread and wxPython-

Fernando Perez Fernando.Perez at colorado.edu
Tue Oct 5 12:40:23 CDT 2004

Prabhu Ramachandran schrieb:
>>>>>>"FP" == Fernando Perez <Fernando.Perez at colorado.edu> writes:
>     FP> Prabhu Ramachandran schrieb:
>     >> Here is a simple test you can run:
>     >>
>     >> import gui_thread gui_thread.start() from gui_thread.examples
>     >> import SimpleFrame a = SimpleFrame() a.Show() a.SetTitle('Hey!
>     >> this works!')
>     FP> Mmh :( With scipy CVS from a moment ago, this is what I'm
>     FP> getting:
>     FP> /home/fperez/test/<string> in new_wxSize(*args, **kws)
>     FP> AttributeError: AttrHolder instance has no attribute 'result'
> That is wierd I agree but could be due to the first import, my
> suspicion is that I need to increase the timeout on the Event object
> from 0.5 to a full second or two.  In anycase just try it again (exit
> ipython and restart immediately) and it should work.

No, no luck.  I tried several quick restarts, with the same results.  And I 
get the same problem with the wx demo (after fixing the args):

In [1]: import gui_thread

In [2]: gui_thread.start()

In [3]: import Main

In [4]: d = Main.wxPythonDemo(None,-1, 'a')
AttributeError                            Traceback (most recent call last)


/usr/share/doc/wxPythonGTK2- in __init__(self, parent, id, 
     298     def __init__(self, parent, id, title):
     299         wx.Frame.__init__(self, parent, -1, title, size = (800, 600),
--> 300 
     302         self.cwd = os.getcwd()

/usr/lib/python2.3/site-packages/wxPython/frames.py in __init__(self, *_args, 
     149 class wxFrame(wxFramePtr):
     150     def __init__(self,*_args,**_kwargs):
--> 151         self.this = framesc.new_wxFrame(*_args,**_kwargs)
     152         self.thisown = 1
     153         self._setOORInfo(self)

/usr/share/doc/wxPythonGTK2-<string> in new_wxFrame(*args, **kws)

AttributeError: AttrHolder instance has no attribute 'result'

Furthermore, with the SimpleFrame example, now things hang when I try to quit 
ipython.  And once I hit Ctrl-C, I get the following (truncated) message:

Exception exceptions.AttributeError: <exceptions.AttributeError instance at 
0x2a88504c> in

I don't know why the message gets truncated, I tried maximizing the terminal 
and it still is incomplete.

Something isn't quite right here...



More information about the Scipy-dev mailing list