[SciPy-dev] Final release of Numeric is actually 24.1

Nils Wagner nwagner at mecha.uni-stuttgart.de
Fri Nov 4 01:32:36 CST 2005

Travis Oliphant wrote:
>I made a final release of Numeric (24.1).  This is "really" the last 
>release of Numeric ;-)
>I did it because of David Cooke's excellent array_protocol enhancement 
>of __array_struct__.  I wanted to make sure the final Numeric fully 
>supported the array protocol including the "faster version."
>I also tracked down a bug today in scipy core that was inherited from 
>Numeric.   A part of me wanted to not fix the bug in Numeric so that 
>people who need a stable platform will move to scipy core :-)  But the 
>better part of me won, and I fixed the problem and made a new Numeric 
>I do hope people are encouraged to move toward scipy core, however.  It 
>is stabilizing quite rapidly.  All of scipy now builds with the new 
>scipy core, and all of (full) scipy's 1300 tests pass for both 32-bit 
>and 64-bit systems.   I will be making a release of scipy_core (probably 
>called version 0.6 this weekend).  It is still missing finished 
>records.py, ma.py, and chararray.py modules (being worked on).   When 
>these are available I will make release of scipy core version 1.0
>Best regards,
>Scipy-dev mailing list
>Scipy-dev at scipy.net
Hi Travis,

I cannot confirm that all tests pass (at least when ATLAS is n o t
I still get these nasty failure/error messages
ERROR: check_nils (scipy.linalg.matfuncs.test_matfuncs.test_logm)
Traceback (most recent call last):
line 82, in check_nils
"/usr/local/lib/python2.4/site-packages/scipy/linalg/matfuncs.py", line
232, in logm
    errest = norm(expm(F)-A,1) / norm(A,1)
  File "/usr/local/lib/python2.4/site-packages/scipy/linalg/basic.py",
line 255, in norm
    x = asarray_chkfinite(x)
line 211, in asarray_chkfinite
    raise ValueError, "array must not contain infs or NaNs"
ValueError: array must not contain infs or NaNs

FAIL: check_nils (scipy.linalg.matfuncs.test_matfuncs.test_signm)
Traceback (most recent call last):
line 44, in check_nils
  File "/usr/local/lib/python2.4/site-packages/scipy/test/testing.py",
line 735, in assert_array_almost_equal
    assert cond,\
Arrays are not almost equal (mismatch 100.0%):
        Array 1: [[  1.2104571e+01 -2.3056788e-02j  -1.0034348e+00
    1.5239715e+01 +1.1528394e-02j   2.1808571e+01 -2.3...
        Array 2: [[ 11.9493333  -2.2453333  15.3173333  21.6533333 
 [ -3.8426667   0.4986667  -4.5906667  -7.1866667   0.498...

Ran 1319 tests in 7.417s

FAILED (failures=1, errors=1)

And how about this message
>>import scipy
Importing signal to scipy
Failed to import signal
cannot import name comb


More information about the Scipy-dev mailing list