[SciPy-dev] scipy.test() 15 failures

Joe Cooper joe at enthought.com
Fri Nov 4 04:03:27 CST 2005

Hi all,

This has been discussed in the past, with the reported solution being a
change of Atlas build, but I'm having no luck making that work for me.
Here's the error:

ERROR: check_sh_legendre (scipy.special.basic.test_basic.test_sh_legendre)
Traceback (most recent call last):
line 1806, in check_sh_legendre
     Ps1 = sh_legendre(1)
   File "/usr/lib/python2.3/site-packages/scipy/special/orthogonal.py",
line 593, in sh_legendre    x,w,mu0 = ps_roots(n,mu=1)
   File "/usr/lib/python2.3/site-packages/scipy/special/orthogonal.py",
line 584, in ps_roots
     return js_roots(n,1.0,1.0,mu=mu)
   File "/usr/lib/python2.3/site-packages/scipy/special/orthogonal.py",
line 205, in js_roots
     val = gen_roots_and_weights(n,an_Js,sbn_Js,mu0)
   File "/usr/lib/python2.3/site-packages/scipy/special/orthogonal.py",
line 121, in gen_roots_and_weights
     eig = get_eig_func()
   File "/usr/lib/python2.3/site-packages/scipy/special/orthogonal.py",
line 91, in get_eig_func    eig = scipy.linalg.eig
AttributeError: 'module' object has no attribute 'eig'

Ran 865 tests in 1.131s

FAILED (errors=15)
<unittest.TextTestRunner object at 0xb703372c>

Previous discussion of seemingly this exact error from November of 2004:


I would like to use a scipy snapshot of scipy from a couple of months
ago (because it is what is in the upcoming Windows Enthon release), but
I just upgraded scipy_core to the very latest Subversion checkout from
about an hour ago, which I was under the impression was where the
problem occurs.  I've tried setting environment variable PTATLAS="None"
with no impact (against both a threaded and non-threaded Atlas).  I've
tried building a threaded and non-threaded Atlas, and I've tried using
an atlas binary from SciPy.org (which actually did worse and
segfaulted--but perhaps I tried the wrong one for my architecture).
Finally, I've tried not using Atlas, and just using the standard blas
and lapack, which results in a different set of test failures--I believe
Nils or someone has already reported the problems with standard blas and
lapack, so I won't worry over them for now.

Anyway, in all Atlas-built cases, except the binaries from SciPy.org, I
get the same errors=15 and the same eig error at the end of the tests.

Platform is Red Hat Enterprise Linux 3.5 with Python 2.3.5, Numeric
23.8, a recent F2PY, and two different scipy_core packages (one from the
same time as the SciPy snapshot, and another from today).

The same SciPy snapshot is working fine with the same version of Atlas
(4.6.0) on Windows, so I'm out of ideas.

Anyone have a clue they can lend me?

More information about the Scipy-dev mailing list