[SciPy-dev] missing Lib/__init__.py in newscipy?

Robert Cimrman cimrman3 at ntc.zcu.cz
Wed Oct 19 03:22:16 CDT 2005

Robert Cimrman wrote:
>>Hi Pearu,
>>I must be doing something wrong here. I deleted my old scipy and Numeric 
>>directories from site-packages, then I checked out from svn:
>>svn co http://svn.scipy.org/svn/scipy_core/branches/newcore/
>>svn co http://svn.scipy.org/svn/scipy/branches/newscipy/
>>Then I copied site.cfg to newcore/scipy/distutils, built and installed 
>>newcore. At this point, I run test(1,0) and get the three errors related to 
>>signbit which I reported earlier. Next I built and installed newscipy, and 
>>when I try to import scipy:
>>In [1]: from scipy import *
>>Importing io to scipy
>>Importing special to scipy
>>Segmentation fault
> same for me on Gentoo Linux after a complete reinstall:
> svn co http://svn.scipy.org/svn/scipy_core/branches/newcore/
> cd newcore
> python setup.py install --root=/home/share/software
> svn co http://svn.scipy.org/svn/scipy/branches/newscipy/
> cd newscipy
> python setup.py install --root=/home/share/software
> In [1]:import scipy
> Importing io to scipy
> Importing special to scipy
> Segmentation fault (SIGSEGV)
> r.

update: I have commented out 'config.add_subpackage('special')' in 
newscipy/Lib/setup.py, reinstalled, and voila:

In [1]:import scipy
Importing utils to scipy
Importing io to scipy
Importing optimize to scipy
Importing interpolate to scipy
Importing linalg to scipy

scipy.test then fails, but that's other thing. what is so offending in 
'special' package? namely what has changed since 
beginnign-of-last-week's revisions of newscipy? 'import scipy' worked 
for me then...


More information about the Scipy-dev mailing list