[SciPy-dev] Trouble with UMFPACK 5.0

Robert Cimrman cimrman3 at ntc.zcu.cz
Thu Dec 14 06:19:40 CST 2006

Nils Wagner wrote:
> Robert Cimrman wrote:
>> Nils Wagner wrote:
>>>> I am puzzled. It might be a 64-bit issue? Could you send me the relevant 
>>>> part of compilation output?
>>> How can I redirect the output of python setup.py install into a file ?
>> python setup.py install &> out.txt (using bash shell, both standard 
>> output and atandard error are redirected)
>> or just
>> python setup.py install > out.txt (standard output only)
>> r.
>> _______________________________________________
>> Scipy-dev mailing list
>> Scipy-dev at scipy.org
>> http://projects.scipy.org/mailman/listinfo/scipy-dev
> Ok I will send you out.txt off-list.


I have tried umfpack on 64 bits, fresh scipy install.
To get it compiled, just copy UFconfig.h into the directory where you 
have umfpack.h (..UFsparse/UMFPACK/Include). Then everything works like 
a charm.

Ran 1616 tests in 78.011s
Out[2]: <unittest.TextTestRunner object at 0x2ad8f7696ad0>

I am clueless why only the first path specified in site.cfg is taken 
into account (I have tried both ',' and ':' as separators). Does anybody 
here have an idea?

include_dirs = ..../UFsparse/UMFPACK/Include:..../UFsparse/UFconfig
- the second path is ignored


More information about the Scipy-dev mailing list