[SciPy-dev] numpy with icc

Arnd Baecker arnd.baecker at web.de
Wed Jan 18 06:09:34 CST 2006


I tried to compile numpy using the intel compiler.
Apart from the huge amount of messages (61 warnings, 2265 remarks)
it compiles, but on import I get:

In [1]: import numpy
import core -> failed:
undefined symbol: ?1__serial_memmove
import random -> failed: 'module' object has no attribute 'dtype'
import lib -> failed:
undefined symbol: ?1__serial_memmove
Fatal Python error: can't initialize module lapack_lite

Googling for serial_memmove reveals this message

So this one seems needed:
  libirc: Intel-specific C runtime library.
  (note, there is also a
  libircmt Multithreaded Intel-specific C runtime library. )

Therefore I tried:

export FC_VENDOR=Intel
export F77=ifort
export CC=icc
export CXX=icc
   python setup.py config --compiler=intel  --libraries="irc"   install
--prefix=$DESTnumpyDIR | tee ../build_log_numpy_${nr}.txt

However, in the build log I only found -lirc for
the config_tests but nowhere else.
What should I do instead of the above?

((What I am also not sure about is, whether this -lirc is needed
in general or specific to our situation. The reason is
that python2.4 was compiled with gcc and numpy with icc9.1_beta.))



More information about the Scipy-dev mailing list