[SciPy-dev] scipy-0.4.6 Adjust D1MACH by uncommenting data statements

Neal Becker ndbecker2 at gmail.com
Tue Mar 7 07:30:09 CST 2006

Robert Kern wrote:

> Neal Becker wrote:
>> Robert Kern wrote:
>>>Neal Becker wrote:
>>>>I just tried a little test on Fedora FC5 (x86_64) that used
>>>>integrate.quad and the function special.i0e, and go:
>>>> Adjust D1MACH by uncommenting data statements
>>>> appropriate for your machine.
>>>>STOP 779
>>>Someone else ran into this a bit earlier. He tracked down the problem to
>>>gfortran. Using g77 instead solved his problem.
>> Thanks.  I wonder if anyone knows of a way to fix this so it works with
>> gfortran?
> Possibly a more recent version of gfortran will help. Of course, I'm
> willing to bet that the only reason most people here are using gfortran is
> because their Linux distro had gcc 4 installed by default.
>   http://gcc.gnu.org/bugzilla/show_bug.cgi?id=18518

Compiling d1mach.f with -O rather than -O2 fixes it also.

How can I patch scipy to compile only d1mach.f using -O?

More information about the Scipy-dev mailing list