[SciPy-dev] numpy.random.randint

"Johannes Löhnert" a.u.r.e.l.i.a.n at gmx.net
Fri Mar 10 10:36:49 CST 2006


I just noticed that in function numpy.random.randint,
the shape=... keyword was replaced by size=...

I find this somewhat counterintuitive, as it denotes
the _shape_ of the desired array (as tuple),
although it also takes integer values. Also it is an
unnecessary break with backwards compatibility (to RandomArray).

I would suggest to allow both "shape" & "size", with "shape"
having precedence.


"Feel free" mit GMX FreeMail!
Monat für Monat 10 FreeSMS inklusive! http://www.gmx.net

More information about the Scipy-dev mailing list