[SciPy-dev] Requiring Python 2.4
Stefan van der Walt
Tue Aug 28 18:30:53 CDT 2007
On Tue, Aug 28, 2007 at 04:01:36PM -0700, Jarrod Millman wrote:
> On 8/28/07, Robert Kern <email@example.com> wrote:
> > On the other hand, if there were a great influx of developers who had never seen
> > a Python older than 2.4, that might be a good reason to switch, too. But until
> > then, I think the rest of us can have the discipline to use only features from
> > 2.3. It's not that hard.
> I agree. Let's at least table the discussion for now; we can return
> to this question later.
> And since it doesn't sound like any Python 2.4 features have sneaked
> in, the 0.6 release will still be compatible with Python 2.3. Please
> correct me if I am missing something.
Shouldn't be a problem. I'm now compiling 2.3.6 from source, so if no
one else gets around to it, I'll make sure that everything is in order
tomorrow morning (GMT+2). The buildbot clients all run 2.4, 2.5
(mainly) and 2.6; I should add a machine running 2.3 as well.
More information about the Scipy-dev