[SciPy-dev] Strange scipy.test crashes on OS X/Intel

Tom Loredo loredo@astro.cornell....
Thu Sep 27 13:11:04 CDT 2007

Hi folks-

With the problems I've been having with scipy-0.6.0 on RHEL 5, and my
colleague with it on FC4, I experimented with it on my OS X machines.

MacBook (Intel), OS 10.4, Python 2.5.1, numpy

Running scipy.test() the 1st time completed 1719 tests and reported 5

FAIL: check_cosine_weighted_infinite (scipy.integrate.tests.test_quadpack.test_quad)
FAIL: check_sine_weighted_finite (scipy.integrate.tests.test_quadpack.test_quad)
FAIL: check_sine_weighted_infinite (scipy.integrate.tests.test_quadpack.test_quad)
FAIL: check_dot (scipy.lib.tests.test_blas.test_fblas1_simple)
FAIL: check_x_stride (scipy.lib.blas.tests.test_fblas.test_cgemv)

I ran it again (in the same Python invocation) and got 4 of the 5 failures
(all but check_x_stride).

I ran it a third time, and it crashed with a seg fault:

    Found 42 tests for scipy.lib.lapack
    Found 41 tests for scipy.linalg.basic
  <module 'scipy.linalg.fblas' from  
  Segmentation fault

The seg fault was 100% repeatable:  Every time I ran scipy.test() a 3rd
time, I got the same seg fault.

I deleted all scipy stuff from site-packages, and tried this again with
scipy  Different tests failed.  I got bus errors or seg faults,
but inconsistently, after 3-5 runs of scipy.test(), and at different
places in the tests (but typically soon after the tests started, i.e.,
after just a few "..." lines).

I removed scipy stuff, and reinstalled 0.6.0.  This time I could run
scipy.test() 9 times before getting a bus error on the 10th run.
Subsequent Python invocations led to bus errors or seg faults sooner
and sooner, until the original behavior was duplicated:  seg fault
on the 3rd run of scipy.test(), always here:

    Found 41 tests for scipy.linalg.basic
  <module 'scipy.linalg.fblas' from  
  Segmentation fault

Subsequently, I always get the same crash on the 3rd run of scipy.test().

I tried similar tests on my G4 (PPC) desktop, OS 10.4, same numpy, but with an
older Python (2.4.4) and scipy  I ran scipy.test() a dozen times
with no problems apart from the 3 failures and 9 errors I've always gotten.

I realize this is inconclusive, as the problem could be with Python 2.5.1 or
gfortran or scipy, but I wanted to report it.  It seems a notable coincidence
that linalg seems involved in the crashes, since it is also giving me problems
on RHEL 5, and my colleague on FC4.

If there is anything further I can do to help diagnose these issues, please


This mail sent through IMP: http://horde.org/imp/

More information about the Scipy-dev mailing list