[SciPy-dev] Should scipy 0.7 be compatible with 1.1 serie at all ?

Robert Kern robert.kern@gmail....
Wed Oct 22 08:37:32 CDT 2008

On Wed, Oct 22, 2008 at 08:20, David Cournapeau
<david@ar.media.kyoto-u.ac.jp> wrote:
> Robert Kern wrote:
>> There is no backwards compatibility with 1.1.x to keep. scipy 0.7-svn
>> has required numpy 1.2-svn for some time.
> Great, thanks for the information. Would it be ok to add a guard against
> using numpy < 1.2  when importing scipy in the trunk ?

You can issue a warning, but I would prefer that we not absolutely prevent it.

Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma that is made terrible by our own mad attempt to interpret it as
though it had an underlying truth."
  -- Umberto Eco

More information about the Scipy-dev mailing list