[SciPy-dev] installing openopt

dmitrey dmitrey.kroshko@scipy....
Sun Sep 21 13:29:09 CDT 2008

Johann Cohen-Tanugi wrote:
> hi there,
> how do I switch off installation of numpy 1.1.1 on my linux box? I have 
> numpy '1.3.0.dev5834' but it does not seem to be recognized by openopt 
> when I  launch python setup.py install
> thanks,
> Johann
I didn't put any numpy version requirements into setup.py file. If the 
problem still somehow exist it's better to search an answer in 
setuptools mail list.

Also, to avoid the bug, you could just copy openopt/scikits/* files to 
.../site-packages/scikits directory (latter should be created)

Some minuties ago I have update numpy to latest 1.3.0.dev5858, and OO 
install works ok:
byte-compiling build/bdist.linux-x86_64/egg/scikits/__init__.py to 
creating build/bdist.linux-x86_64/egg/EGG-INFO
copying scikits.openopt.egg-info/PKG-INFO -> 
copying scikits.openopt.egg-info/SOURCES.txt -> 
copying scikits.openopt.egg-info/dependency_links.txt -> 
copying scikits.openopt.egg-info/namespace_packages.txt -> 
copying scikits.openopt.egg-info/requires.txt -> 
copying scikits.openopt.egg-info/top_level.txt -> 
copying scikits.openopt.egg-info/zip-safe -> 
creating dist
creating 'dist/scikits.openopt-0.19.dev-py2.5.egg' and adding 
'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing scikits.openopt-0.19.dev-py2.5.egg
Copying scikits.openopt-0.19.dev-py2.5.egg to 
Removing scikits.openopt 0.19.dev from easy-install.pth file
Adding scikits.openopt 0.19.dev to easy-install.pth file

Processing dependencies for scikits.openopt==0.19.dev
Searching for numpy==1.3.0.dev5858
Best match: numpy 1.3.0.dev5858
Adding numpy 1.3.0.dev5858 to easy-install.pth file

Using /usr/lib/python2.5/site-packages
Finished processing dependencies for scikits.openopt==0.19.dev

Regards, D.

More information about the Scipy-dev mailing list