[SciPy-dev] Problems packaging GSoC statsmodels code as scikit

Skipper Seabold jsseabold@gmail....
Fri Aug 21 21:09:01 CDT 2009

Hello all,

I have been trying to package the models code using the scikits
template and have run into a problem.

On linux, both Kubuntu 64-bit and openSuSE 32-bit, I can install the
package (sudo python setup.py install), but when I do

from scikits import statsmodels

I get

Running unit tests for scikits.statsmodels
NumPy version 1.4.0.dev7303
NumPy is installed in /usr/local/lib/python2.6/dist-packages/numpy
Python version 2.6.2 (release26-maint, Apr 19 2009, 01:58:18) [GCC 4.3.3]
nose version 0.11.1

Ran 0 tests in 0.003s

Out[2]: <nose.result.TextTestResult run=0 errors=0 failures=0>

Similarly if I try to use nosetests from the command line on the
installed tests folder, I get nothing

skipper@linux-desktop:~$ nosetests -v

Ran 0 tests in 0.003s


However, if I run the nosetests either from the source directory or if
I import the directory statsmodels the tests return errors (which I
expect at this point, due to incomplete refactoring).

skipper@linux-desktop:~$ nosetests -w

Ran 6 tests in 0.188s

FAILED (errors=6)

Josef is able to install the package and run the tests
(statsmodels.test()) and return these errors on Windows with Python

Is there anyone who would be willing to have a look at my setup.py and
see if they spot a problem, because I am at a loss.

My attempt is here.  Also I don't think the tester.py is correct,
though I've tried with and without (and don't think it would affect
this issue).




More information about the Scipy-dev mailing list