[SciPy-dev] binary compatibility question

josef.pktd@gmai... josef.pktd@gmai...
Sat May 16 05:36:47 CDT 2009

On Fri, May 15, 2009 at 11:06 PM, David Cournapeau
<david@ar.media.kyoto-u.ac.jp> wrote:
> josef.pktd@gmail.com wrote:
>> On Fri, May 15, 2009 at 9:39 AM,  <josef.pktd@gmail.com> wrote:
>>> I didn't follow the discussion of binary compatibility between
>>> different versions very closely.
>>> I compiled scipy 0.7.1 against numpy 1.3.0 and ran it in a virtualenv
>>> against numpy 1.2.1 and I get an immediate segfault when trying to run
>>> scipy.test(). I get the usual 4 failures when I run scipy with numpy
>>> 1.3.0
>>> Is this expected?
>>> (I didn't do it on purpose, the version mismatch was just a
>>> consequence of how I wanted to setup my testing environment for scipy
>>> 0.7.1 and is easily fixed)
>> I build scipy 0.7.1 against numpy 1.2.1 (official installer) and I get
>> the same segfault. I get it already trying to `import scipy.stats`
> This is strange. Did you remove the build directory and the previously
> installed scipy before building scipy 0.7.1 against 1.2.1 ? This should
> definitely work. I am testing it ATM,

I removed the build directory between builts, but I had a recent scipy
trunk on the python path, since this usually didn't cause any problems
for the building. I followed my usual procedure for compiling scipy,
but I had never tried with a downgraded numpy before.

If the build of  scipy 0.7.1 against numpy 1.2.1 works for you, then I
will check everything to see why my usual setup didn't work for this



More information about the Scipy-dev mailing list