[SciPy-dev] Fwd: scipy.test() failures

David Goldsmith d.l.goldsmith@gmail....
Wed Oct 21 21:42:50 CDT 2009

Hi!  I had to admit to this guy that I don't know specifically who our list
admin is; can someone please help him (I already instructed him to login and
make sure none of his settings might be blocking delivery).  Thanks!


---------- Forwarded message ----------
From: Neil Killeen <nkilleen@unimelb.edu.au>
Date: Wed, Oct 21, 2009 at 4:53 PM
Subject: Fwd: scipy.test() failures
To: d.l.goldsmith@gmail.com
Cc: Neil Killeen <nkilleen@unimelb.edu.au>

Dear David
sorry to write to you out of the list, but perhaps you can help !

I signed up to the dev list, but I can't post; my messages do not turn up
and I don't get a bounce or a copy. I have written twice to the
administrator (below) but no answer.

Do you happen to know who the admin is (they could be away
of course) or suggest a course of action ?

You might even know the solution to my problem (below)

Neil Killeen

p.s. I only picked you as you are the last poster !

Begin forwarded message:

*From: *Neil Killeen <nkilleen@unimelb.edu.au>
*Date: *21 October 2009 10:12:14 AM
*To: *Neil Killeen <nkilleen@unimelb.edu.au>
*Cc: *scipy-dev-owner@scipy.org
*Subject: **Re: scipy.test() failures*

I tried again without attachments but still no success.
Can you please resolve why I can't post to the list ?


On 19/10/2009, at 9:59 , Neil Killeen wrote:

I am a new member of the list. I posted this last week but
it has not turned up on the list

It must have been rejected  for some reason.

can you have a look ?


Begin forwarded message:

*From: *Neil Killeen <nkilleen@unimelb.edu.au>
*Date: *15 October 2009 5:49:53 PM
*To: *scipy-dev@scipy.org
*Cc: *Neil Killeen <nkilleen@unimelb.edu.au>
*Subject: **scipy.test() failures*


- I am operating on an SGI Altix 3700 BX2 Itaniam IA64 system running
SUSE/Novelle Linux SLES10
- I am trying to install scipy V 0.7.1
- I am using python 2.4
- blas and lapack are installed via system rpms in /usr/lib

soma:/usr/lib # ls -al *blas* *lapack*
-rw-r--r-- 1 root root   929506 2007-04-14 02:16 libblas.a
lrwxrwxrwx 1 root root       12 2008-03-12 12:20 libblas.so -> libblas.so.3
lrwxrwxrwx 1 root root       16 2008-03-12 12:20 libblas.so.3 ->
-rwxr-xr-x 1 root root   678024 2007-04-14 02:16 libblas.so.3.0.0
lrwxrwxrwx 1 root root       20 2008-12-02 22:52 libgslcblas.so.0 ->
-rwxr-xr-x 1 root root   908816 2007-04-14 02:30 libgslcblas.so.0.0.0
-rw-r--r-- 1 root root 11208466 2007-04-14 02:16 liblapack.a
lrwxrwxrwx 1 root root       14 2008-03-12 12:20 liblapack.so ->
lrwxrwxrwx 1 root root       18 2008-03-12 12:20 liblapack.so.3 ->
-rwxr-xr-x 1 root root  7503568 2007-04-14 02:16 liblapack.so.3.0.0

1. I did a vanilla build (python setup.py build/install) which appeared to
work ok.

2. When I tried to run scipy.test()  I saw errors (see attachment 1).  They
are in two categories:

   ERROR: Failure: ImportError
(/usr/local/lib/python2.4/site-packages/scipy/linalg/fblas.so: undefined
symbol: srotmg_)


 ImportError: cannot import name {linalg, calc_lwork}

  Perhaps the latter are due to the former ?

3. I read in the FAQ that the solution to the srotmg error is to install
blas myself either from netlib or via ATLAS

4. I decided to do the easy thing and installed blas from netlib in

5. I then deleted the scipy installation
(/usr/local/lib/python2.4/site-packges/scipy)  and rebuilt and installed

    YOu can see in attachment 2 (the build log) that it appears to have
found the /usr/local/lib/libblas.a library


   libraries = ['blas']
   library_dirs = ['/usr/local/lib']
   language = f77

   libraries = ['blas']
   library_dirs = ['/usr/local/lib']
   define_macros = [('NO_ATLAS_INFO', 1)]
   language = f77

6. Then I
   - set env variable BLAS=/usr/local/lib/libblas.a   (not sure useful since
static library so should be no run-time dependency)
   - ran the test again with the same result as the initial.

Can someone advise what more I must do to eradicate these run-time errors ?



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20091021/45e4a980/attachment-0001.html 

More information about the Scipy-dev mailing list