[SciPy-dev] scipy.test() failures

Neil Killeen nkilleen@unimelb.edu...
Thu Oct 22 17:23:57 CDT 2009

Hi all


- I am operating on an SGI Altix 3700 BX2 Itanium IA64 system running  
SUSE/Novelle Linux SLES10
- I am trying to install scipy V 0.7.1
- I am using python 2.4
- blas and lapack are installed via system rpms in /usr/lib

soma:/usr/lib # ls -al *blas* *lapack*
-rw-r--r-- 1 root root   929506 2007-04-14 02:16 libblas.a
lrwxrwxrwx 1 root root       12 2008-03-12 12:20 libblas.so ->  
lrwxrwxrwx 1 root root       16 2008-03-12 12:20 libblas.so.3 ->  
-rwxr-xr-x 1 root root   678024 2007-04-14 02:16 libblas.so.3.0.0
lrwxrwxrwx 1 root root       20 2008-12-02 22:52 libgslcblas.so.0 ->  
-rwxr-xr-x 1 root root   908816 2007-04-14 02:30 libgslcblas.so.0.0.0
-rw-r--r-- 1 root root 11208466 2007-04-14 02:16 liblapack.a
lrwxrwxrwx 1 root root       14 2008-03-12 12:20 liblapack.so ->  
lrwxrwxrwx 1 root root       18 2008-03-12 12:20 liblapack.so.3 ->  
-rwxr-xr-x 1 root root  7503568 2007-04-14 02:16 liblapack.so.3.0.0

1. I did a vanilla build (python setup.py build/install) which  
appeared to work ok.

2. When I tried to run scipy.test()  I saw errors.  They are in two  

   ERROR: Failure: ImportError (/usr/local/lib/python2.4/site-packages/ 
scipy/linalg/fblas.so: undefined symbol: srotmg_)


ImportError: cannot import name {linalg, calc_lwork}

  Perhaps the latter are due to the former ?

3. I read in the FAQ that the solution to the srotmg error is to  
install blas myself either from netlib or via ATLAS

4. I decided to do the easy thing and installed blas from netlib in / 

5. I then deleted the scipy installation (/usr/local/lib/python2.4/ 
site-packges/scipy)  and rebuilt and installed afresh.

   In the build log one can see that it appears to have found the /usr/ 
local/lib/libblas.a library


   libraries = ['blas']
   library_dirs = ['/usr/local/lib']
   language = f77

   libraries = ['blas']
   library_dirs = ['/usr/local/lib']
   define_macros = [('NO_ATLAS_INFO', 1)]
   language = f77

6. Then I
   - set env variable BLAS=/usr/local/lib/libblas.a   (not sure useful  
since static library so should be no run-time dependency)
   - ran the test again with the same errors resulting as the initial.

Can someone advise what more I must do to eradicate these run-time  
errors ?


p.s. tried to post this last week but message did not arrive (perhaps  
as I included attachments
which I have left off this time)

More information about the Scipy-dev mailing list