[SciPy-Dev] RFR: N-dimensional interpolation

Pauli Virtanen pav@iki...
Tue Aug 31 17:28:03 CDT 2010

Tue, 31 Aug 2010 18:24:48 -0400, David Warde-Farley wrote:
> One comment: the name "griddatand" looks odd to my eyes, my mind wants
> to group it as "datand". I only mention this because it might slip past
> someone who's looking for "griddata"

"griddatand" is the name of the module, and probably nobody will need to 
use it since the stuff is imported to top-level scipy.interpolate. 
(I can't use "griddata" there since it would shadow the function name.)

> (also, does np.lookfor match partial words?). 


> I don't really have a suggestion of another name
> though. "ndgriddata"? Then griddata looks a bit more separate, and it'd
> match scipy.ndimage.

That might be a slightly better name, yes.

Pauli Virtanen

More information about the SciPy-Dev mailing list