[SciPy-Dev] np.savetxt: apply patch in enhancement ticket 1079 to add headers?

Stefan stefan.czesla@hs.uni-hamburg...
Tue Jun 8 10:51:33 CDT 2010

Hi all,
dear Bruce and Skipper,

we very much appreciate your feedback. In response to Skipper's
annotation we added a paragraph in the notes section and also
tried to indicate the purpose of the keywords more precisely in
the parameter section.

The keyword renaming suggested by Bruce lead to some internal
discussions here. We also were not 100% satisfied with the
'comments-comment_character' solution proposed in the first patch, and
we see the conflict with loadtxt. Yet, also the combination of
'Preamble-Comments' appears, somewhat, awkward, because
both seem to indicate the same, at least in our opinion.
We appreciate Bruce's suggestion to
call the keyword Preamble, because it expresses its purpose 
much more clearly than 'Comments' did. For the same reason, we decided
to stay with 'comment_character' instead of 'Comments'.
For the sake of clarity, this solution sacrifices
full compatibility with np.loadtxt,
but it does not create a conflict either.

An adapted patch is available via ticket 1079 at:

Christian & Stefan

More information about the SciPy-Dev mailing list