[Scipy-tickets] [SciPy] #1180: scipy-0.7.2 does not build with python-2.7

SciPy Trac scipy-tickets@scipy....
Thu Jul 8 11:27:42 CDT 2010

#1180: scipy-0.7.2 does not build with python-2.7
 Reporter:  bicatali      |       Owner:  cdavid
     Type:  defect        |      Status:  new   
 Priority:  normal        |   Milestone:  0.8.0 
Component:  Build issues  |     Version:  0.7.0 
 Keywords:                |  

Comment(by bsouthey):

 The sparse compilation is specific numpy error that is not new (see
 below). It is apparently due to c++ code and the compiler. While it
 complies using Python 2.6 it fails under Python 2.7 on the same system and

 My compiler gcc version 4.4.4 20100503 (Red Hat 4.4.4-2) (GCC) on Fedora
 13 64-bit. Interesting Python 2.6 is using g++ but Python 2.7 is using gcc
 as well as different flags:

 C compiler: g++ -pthread -fno-strict-aliasing -fwrapv -Wall -g -fPIC

 C compiler: gcc -pthread -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv
 -O3 -Wall -Wstrict-prototypes -fPIC

 Aug 2008:

 June 2009:

 Scipy builds when make David's hack:

Ticket URL: <http://projects.scipy.org/scipy/ticket/1180#comment:7>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.

More information about the Scipy-tickets mailing list