[Scipy-tickets] [SciPy] #1500: Build issues with llvm-gcc on OS X 10.7 (Lion)

SciPy Trac scipy-tickets@scipy....
Wed Jan 25 16:08:37 CST 2012

#1500: Build issues with llvm-gcc on OS X 10.7 (Lion)
 Reporter:  rgommers      |       Owner:  cdavid     
     Type:  defect        |      Status:  new        
 Priority:  normal        |   Milestone:  Unscheduled
Component:  Build issues  |     Version:  devel      
 Keywords:                |  

Comment(by samuel):

 Interesting. I was not aware of these other prebuilt binaries. Thx.
 The homebrew version, however, works, iff I compile scipy with gcc instead
 of llvm-gcc. Note that `pip install scipy` will use the llvm-gcc version
 as it is the default on Lion. I think the r.research.att.com version is
 built against non llvm version as it says here (if I am reading that

 gfortran -print-libgcc-file-name

 I am downloading the gfortran from gcc.gnu.org and will test compilation
 of numpy/scipy.

Ticket URL: <http://projects.scipy.org/scipy/ticket/1500#comment:6>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.

More information about the Scipy-tickets mailing list