[Scipy-tickets] [SciPy] #1513: test_singular (test_linsolve.TestLinsolve) ... Segmentation fault

SciPy Trac scipy-tickets@scipy....
Tue Jan 31 16:38:16 CST 2012

#1513: test_singular (test_linsolve.TestLinsolve) ... Segmentation fault
  Reporter:  samuel        |       Owner:  somebody               
      Type:  defect        |      Status:  closed                 
  Priority:  normal        |   Milestone:  Unscheduled            
 Component:  scipy.linalg  |     Version:  0.9.0                  
Resolution:  invalid       |    Keywords:  segfault, linux, gentoo
Changes (by pv):

  * status:  new => closed
  * resolution:  => invalid


 This is a bug in SuperLU. Scipy ships with a patched version of the
 library (ideally, the fix would be pushed upstream...). Apparently, on the
 Gentoo system, the library is linked against the system version of

 The solution is to link Scipy against the bundled version of the library.
 This should usually happen automatically, but Gentoo probably modifies
 Scipy's build scripts so that the system library is used.

Ticket URL: <http://projects.scipy.org/scipy/ticket/1513#comment:5>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.

More information about the Scipy-tickets mailing list