[Scipy-tickets] [SciPy] #1646: Could not find file error from setup.py build

SciPy Trac scipy-tickets@scipy....
Wed Jul 18 01:15:20 CDT 2012

#1646: Could not find file error from setup.py build
 Reporter:  bdpy          |       Owner:  somebody   
     Type:  defect        |      Status:  new        
 Priority:  normal        |   Milestone:  Unscheduled
Component:  Build issues  |     Version:  0.10.0     
 Keywords:                |  

Comment(by bohoro):

 Replying to [comment:7 rgommers]:
 > Scipy Superpack not finishing installing may be the reason for your
 troubles. I don't think it makes sense for me to try to reproduce this
 issue then.
 > I would suggest either trying that installer again (after cleaning up
 the broken parts by hand) or installing python, numpy and scipy from their
 binary installers. Those can be found on python.org and sourceforge.

 My steps for posterity

 Cleaned up stuff....

 sudo easy_install -mxN scipy

 rm -Rf  /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7
 rm -Rf /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7


 Verified Python does not see scipy

 Python 2.7.3 (v2.7.3:70274d53c1dd, Apr  9 2012, 20:52:43)
 [GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin
 Type "help", "copyright", "credits" or "license" for more information.
 >>> import scipy
 Traceback (most recent call last):
   File "<stdin>", line 1, in <module>
 ImportError: No module named scipy


 Did a find command on filesystem for "scipy" looked clean.

 Tried easy install and pip for scipy both complained about umfpack, pip


   libraries umfpack not found in

   libraries umfpack not found in /usr/local/lib

   libraries umfpack not found in /usr/lib


     UMFPACK sparse solver

     not found. Directories to search for the libraries can be specified in

     numpy/distutils/site.cfg file (section [umfpack]) or by setting

     the UMFPACK environment variable.




 ran brew install umfpack

 Reran PIP and easy_setup - still no dice, no error just did not install.
 Gave up went to binary install.

 Install worked, but failures in scipy.test() equiv to:


 From the mail list:


 The failures seem to indicate that (single-precision) linear algebra
 routines are not functioning correctly. These are probably a sign of
 some Veclib / Fortran ABI mismatch related to Fortran functions --
 similar problems have been seen e.g. when mixing g77 and gfortran
 compilers (also on other platforms than OSX), and on OSX adding Veclib
 to the mix seems make the situation even more finicky.

Ticket URL: <http://projects.scipy.org/scipy/ticket/1646#comment:8>
SciPy <http://www.scipy.org>
SciPy is open-source software for mathematics, science, and engineering.

More information about the Scipy-tickets mailing list