[SciPy-user] Re: [SciPy-dev] issues with distributing Numeric separately on windows

Steve M. Robbins steven.robbins at videotron.ca
Fri Apr 5 09:53:54 CST 2002

On Fri, Apr 05, 2002 at 09:33:42AM -0600, pearu at scipy.org wrote:

> Personally and in general, I would not feel good if some package
> overwrites already installed version of it. 

Yes, I agree.

> It might happen that the
> installed version of the package is newer and as a result the overwrite
> would break this package (as it may contain new features, bug fixes).

Though now fixed, this has happened to me with the Debian packages in
the past.  It is quite a nuisance.

I realise the current discussion is about the MS windows packaging.
I presume that the Debian packager could continue to keep 'em separated?

> And to make clear for Windows installers that SciPy will work only with
> gcc compiled Numeric. May be it is possible to check that
> the correct Numeric is used already in the SciPy setup.py script and it
> would raise an exception if Numeric is not compiled with gcc.

Presumably you could build a test based on the code that is known to
fail --- that in eric's message?


by Rocket to the Moon,
by Airplane to the Rocket,
by Taxi to the Airport,
by Frontdoor to the Taxi,
by throwing back the blanket and laying down the legs ...
- They Might Be Giants

More information about the SciPy-user mailing list