[SciPy-user] clapack--installation problem

Pearu pearu at scipy.org
Tue Aug 20 02:30:15 CDT 2002

On Mon, 19 Aug 2002, Giovanni Montana wrote:

> > You can also look to system_info.py file, in particular, the definition of
> > atlas_info class and put some print commands inside the calc_info method
> > to see at what point this method is failing. You can print out variables
> > like lib_dirs, lapack_libs, atlas_libs, etc.
> Yes, I've played a bit with those variables, ect. and managed to let scipy 
> find the ATLAS folder, but NOT the souces. 

If you have ATLAS, then you don't need any sources.

> This is the outout when running 
> system_info.py (modified to display where it's looking for sources):
> atlas_info:
>   FOUND:
>     libraries = ['lapack', 'f77blas', 'cblas', 'atlas']
>     library_dirs = ['/usr/lib', '/home/strbr/ATLAS/lib/Linux_P4SSE2_2']

Looks almost good. Except because /usr/lib appears first, scipy will be 
linked against /usr/lib/liblapack.a and that will cause the import errors 
that you get, I believe. Try to get rid of /usr/lib part (I'll try to 
fix it also in scipy_distutils so that it automatically uses lapack only 
from ATLAS lib).

> I wondering whether you could tell me where to look for these sources exactly.

No need for sources.

> Also, is the clapack library supposed to be in the same folder with the other 
> ATLAS libraries? 

There is no clapack library in ATLAS. The only one is the clapack 
shared module in scipy.linalg that scipy should build whenever ATLAS is 

> I still get the same error message when loading the scipy 
> module, so I guess I do need to let scipy find the sources first?

See above the atlas_info part. Also when building, pay attention that the 
wrong lapack library (in /usr/lib) will not be used when linking 


More information about the SciPy-user mailing list