[SciPy-user] scipy OS X compiling on a G3

Pearu Peterson pearu at scipy.org
Mon Feb 9 13:37:03 CST 2004

On Mon, 9 Feb 2004, Jeremy Gore wrote:

> I've tried all sorts of combinations of flags and so forth to get scipy  
> to compile on OS X 10.3.2, but it still won't work for me.  With  
> CFLAGS="-lcc_dynamic -framework vecLib" (and I've also tried with  
> -faltivec and -framework Accelerate) set and using sudo python setup.py  
> install (and have also tried with the build build_ext first) for the  
> CVS version, I get error messages along the lines of:
> In the build.py phase:
> package init file  
> '/Users/jmg75/Programming/scipy/scipy_core/scipy_distutils/tests/ 
> __init__.py' not found (or not a regular file)
> package init file  
> '/Users/jmg75/Programming/scipy/scipy_core/scipy_base/tests/ 
> __init__.py' not found (or not a regular file)
> In the install_data phase:
> fftw_info:
> dfftw_info:
> atlas_info:
> scipy_distutils.system_info.atlas_info
> blas_info:
> Clearly it is not finding the vecLib BLAS libraries.  Whether this is  
> because I'm on a G3 or some other problem I don't know; I was under the  
> impression that although not optimized for altivec the vecLib libraries  
> still processed for G3s.  Any suggestions?

Detecting vecLib BLAS libraries is not implemented in system_info.py yet.
Could you send me the information how one can detect vecLib OSX
and I'll add its support to system_info.py? E.g. which files it should 
look for, or which programs to run and what should be the expected output, 
the values of os.name and sys.platform, etc.


More information about the SciPy-user mailing list