[SciPy-user] tracebacks when running tests

Elliot Peele ebpeele2 at pams.ncsu.edu
Thu Jun 3 15:58:46 CDT 2004

On Thu, 2004-06-03 at 04:42, Pearu Peterson wrote:
> On what system you are running on? How did you install liblapack.a and 
> ATLAS libraries?

Red Hat Enterprise Linux 3

> In principle, scipy can be built also against static libraries even 
> when there exists a shared library with the same name but different 
> contents. Btw, that does not make any sense for me, I would call it a bug 
> in the linux distribution. Anyways, see system_info.py and set 
> search_static_first=1 there.
> A better fix: install atlas libraries to a different directory than 
> /usr/lib, preferably by following instructions in
>   http://www.scipy.org/documentation/buildatlas4scipy.txt
> and then use ATLAS environment variable to point to the location of atlas 
> libraries. As Fernando already (almost) discovered, you don't need to 
> specify ATLAS environment variable when the location of ATLAS libraries
> matches one of the following locations:
>  /usr/local/lib/{atlas*,ATLAS*,sse,3dnow,sse2,}/
>  /opt/lib/{atlas*,ATLAS*,sse,3dnow,sse2,}/
>  /usr/lib/{atlas*,ATLAS*,sse,3dnow,sse2,}/
>  /sw/lib/{atlas*,ATLAS*,sse,3dnow,sse2,}/
>  <sys.prefix>/lib/{atlas*,ATLAS*,sse,3dnow,sse2,}/

I tried compiling atlas and installing it in /usr/lib/atlas/* and now I
get different problems. I get an undefined symbol for s_wsfe in
flapack.so. The ldd output for flapack.so is:

[elliot at rkbuild linalg]$ ldd flapack.so
        libc.so.6 => /lib/tls/libc.so.6 (0xb7166000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

I have also tried changing the system_info.py to use static libs and
that doesn't seem to change anything.

Before I was following the published documentation that comes with scipy
to combine the liblapack.a from lapack and the liblapack.a from atlas
and the atlas symbols just wheren't in liblapack.so.3. I also tried
setting the variable in system_info.py to use static libs and that
didn't seem to change anything.

Also I've noticed a bug in building rpms with setup.py. Since Red Hat's
rpm generates debug packages there are two package to copy into the dist
directory and python's distutils seems to traceback when thats the case.


> Regards,
> Pearu
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-user
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://www.scipy.net/pipermail/scipy-user/attachments/20040603/54ab0f25/attachment.bin

More information about the SciPy-user mailing list