[SciPy-user] Undefined symbol "ATL_cpttrsm"

Lee Harr missive at hotmail.com
Tue Nov 2 16:15:37 CST 2004

>>Actually, I just made a test program to see if I could find acosh
>>and it needs -lm to link in the math library.  I am looking around
>>in system_info.py but I am not sure where to add this ...
>Update scipy_base from CVS and try again. It's setup file now uses -lm
>to link fastumath module.

Well... that change did not make the section use -lm
but I copied and pasted the line and added it by hand and
still get the same error message.

Erm... sorry, but I think that is a wild goose chase.  The error
message from my test program without -lm looks very different:

/tmp/ccRC0xKG.o: In function `main':
/tmp/ccRC0xKG.o(.text+0x16): undefined reference to `acosh'

whereas for scipy the error is:

`acosh' undeclared here (not in a function)
initializer element is not constant
(near initialization for `arccosh_data[0]')

Could it be a compiler error?

I am using:
gcc version 2.95.4 20020320 [FreeBSD]

FREE pop-up blocking with the new MSN Toolbar - get it now! 

More information about the SciPy-user mailing list