[SciPy-user] Undefined symbol "ATL_cpttrsm"

Pearu Peterson pearu at scipy.org
Tue Nov 2 16:51:35 CST 2004

On Wed, 3 Nov 2004, Lee Harr wrote:

>>> Actually, I just made a test program to see if I could find acosh
>>> and it needs -lm to link in the math library.  I am looking around
>>> in system_info.py but I am not sure where to add this ...
>> Update scipy_base from CVS and try again. It's setup file now uses -lm
>> to link fastumath module.
> Well... that change did not make the section use -lm
> but I copied and pasted the line and added it by hand and
> still get the same error message.
> Erm... sorry, but I think that is a wild goose chase.  The error
> message from my test program without -lm looks very different:
> /tmp/ccRC0xKG.o: In function `main':
> /tmp/ccRC0xKG.o(.text+0x16): undefined reference to `acosh'
> whereas for scipy the error is:
> `acosh' undeclared here (not in a function)
> initializer element is not constant
> (near initialization for `arccosh_data[0]')

The errors are different because acosh are used differently in those two 

Try removing `#if !defined(HAVE_INVERSE_HYPERBOLIC)` block from 
fastumath_unsigned.inc. This should ensure that acosh, etc are defined.

If that still does not work then resend build.log to me. May be I can find 
there something off..

> Could it be a compiler error?
> I am using:
> gcc version 2.95.4 20020320 [FreeBSD]

I tried

   gcc version 2.95.4 20011002 (Debian prerelease)

and it works fine on a Debian box.


More information about the SciPy-user mailing list