[SciPy-user] error linking to libg2c on 64-bit machine

Giovanni Samaey Giovanni.Samaey at cs.kuleuven.ac.be
Mon Nov 15 07:28:40 CST 2004

Hi again,

I am sorry I took so long;  I tried a bit and then I got diverted.

> Thanks. These locations look strange enough to be considered as 
> nonstandard locations (I tried google(/apps/prod/local64) and got no 
> results) and using site.cfg might be the proper way to go. See the header
> of scipy_distutils/system_info.py file as well as of sample_site.cfg.

I tried both options;  the system_info.py file gives a lot of categories 
and I did not find which one to use.
I tried setting library_dirs to what was there + what I need.
librtary_dirs = /usr/local/lib/:/opt/lib:/usr/lib:/apps/prod/local64/lib64
(or /apps/prod/local64/lib64 in front).
This didn't make any difference for the error that was reported earlier.
I put this file in the scipy directory once, and also in scipy_distutils.

> Another approach would be to use build_ext -L flag, e.g try
>   python setup.py build_ext -L/apps/prod/local64/lib64 build

This approach gives an error earlier in the process:
running build_ext
Traceback (most recent call last):
  File "setup.py", line 112, in ?
  File "setup.py", line 99, in setup_package
    url = "http://www.scipy.org",
  File "scipy_core/scipy_distutils/core.py", line 73, in setup
    return old_setup(**new_attr)
  File "/data/home/giovanni/lib/python2.3/distutils/core.py", line 149, 
in setup
  File "/data/home/giovanni/lib/python2.3/distutils/dist.py", line 907, 
in run_commands
  File "/data/home/giovanni/lib/python2.3/distutils/dist.py", line 927, 
in run_command
  File "scipy_core/scipy_distutils/command/build_ext.py", line 47, in run
    raise TypeError,'Extension "%s" sources contains unresolved'\
TypeError: Extension "scipy.xxx.spam" sources contains unresolved items 
(call build_src before build_ext).

(Although I did run build_src before build_ext).

> to specify the location of libg2c.so.

> To resolve x11 libraries problem, you should probably use site.cfg file.

I suppose here setting x11_dirs = /apps/prod/xlib64 will do the trick?


More information about the SciPy-user mailing list