[SciPy-user] installing Atlas on Fedora core 2, newbie

J josh8912 at yahoo.com
Sun Sep 12 03:02:51 CDT 2004

I am quite new to the python world...new to the linux
world too.  I have a question on installing atlas.  I
did read the well-written instructions on the scipy
site, but I still have questions. 

I am using a new installation of Fedora core 2, and it
has Blas and Lapack installed.  However, it does not
seem to have atlas installed, or at least neither I
nor the python install script for scipy could find it.
 So I assume I need to install atlas.  But I have

1)  Should I remove the installed versions of Blas and
lapack and then do a complete new install by following
the directions on the scipy web site?  It seems I need
to either do that or do item 2 below.  But if I do do
a new install, I do not know what value to use for the
architecture name in the following line when
installing atlas:

Enter Architecture name (ARCH) [Linux_P4SSE2]:

I am using an AMD Athlon(tm) XP 2600+  machine.  I am
not using SELinux.

2)  I did download the atlas binaries from the scipy
site and could install them, leaving my current
installations of Lapack and Blas intact.  But I dont
know if I should use the atlas3.6.0_Linux_ATHLON.tgz
or the Linux_Athlon.tar.gz files.  I have all the
developer sofware installed on my Fudora box. 
Regarless, all that are in the ziped files are a few
*.a files.  I assume I would need to follow the
directions given:

cp liblapack.a liblapack_orig.a # make a backup
mkdir tmp; cd tmp
ar x ../liblapack.a
cp $LAPACK ../liblapack.a
ar r ../liblapack.a *.o
cd ..; rm -rf tmp

The first four lines of this worked fine.  However, I
do not know what the correct value for $LAPACK should
be or how to set it.  I tried:
# cp $LAPACK ../liblapack.a

but received:
cp: missing destination file

If anyone could shed light on how to proceed, I would
appreciate it.


Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the SciPy-user mailing list