[SciPy-user] python crashes on scipy testing

Bill Dandreta wjdandreta at att.net
Wed Aug 31 20:39:49 CDT 2005

Travis Oliphant wrote:

> This is most likely a problem with ATLAS.  The rest of scipy will 
> probably work fine.  If you don't need that particular ATLAS routine 
> (which in my experience the buggy ATLAS routines are lesser used...) 
> you are good to go.
Compiling from source with Gentoo is usually a piece of cake. That was 
not my problem.

I don't think ATLAS is the only problem either.

I spent the better part of a week trying to get scipy to work with 
Gentoo Linux64 running on an AMD64 CPU. I finally gave up in frustration 
and went back to 32 bit. I tried ATLAS 3.6.0, 3.7.10, and the 
Linux_HAMMER64SSE3 binaries from the ATLAS site. I tried blas/lapack and 
AMD's ACML libraries.

Everything compiles and all tests are OK until the final scipy test that 
always results in "SEGMENTATION FAULT" no matter what level of verbosity 
I tried.

In spite of the test failing, I tried to use scipy anyway. I ran a 
script that works fine on 32 bit Linux. The plot routines didn't work 
correctly. They either plot incorrectly or give an error. I kept the 64 
bit installation on my HD and I planned to post the plot errors here but 
have not had time to get back to it yet.

I don't think 64 bit is 'ready for prime time'. I had problems with 
applications other than scipy. Almost any problem can cause a seg fault 
instead of printing the application's diagnostic information. That's the 
primary reason I went back to 32 bit. I was wasting too much time trying 
to fix problems without having any useful diagnostic information and I 
wasn't getting any work done.


More information about the SciPy-user mailing list