[SciPy-user] scipy on XP isnt happening

Martin Somers msomers at mail.ie
Tue Dec 13 06:09:17 CST 2005

Here all the files that i've been using for my installation 

13/12/2005  12:01    <DIR>          .
13/12/2005  12:01    <DIR>          ..
12/12/2005  17:15         5,114,266 matplotlib-0.85.win32-py2.4.exe
13/12/2005  11:24         1,132,502 numarray-1.5.0.win32-py2.4.exe
13/12/2005  11:23         1,110,177 Numeric-24.2.win32-py2.4.exe
05/12/2005  16:42        10,887,168 python-2.4.msi
06/12/2005  10:12         2,320,640 scipy_core-0.6.1.win32-py2.4.exe
13/12/2005  11:25         2,331,704 scipy_core-0.8.4.win32-py2.4.exe
12/12/2005  13:28           150,318 scipy_distutils-latest.win32.exe
05/12/2005  11:37         5,570,124 wxPython2.6-win32-unicode-
               9 File(s)     28,616,899 bytes
               2 Dir(s)  10,539,999,232 bytes free

when i try installing scipy_core
python setup.build 
python setup.install .....
I get a 

no module named ccomplier error

its an import error when trying to install scipy_core ... main problem seems with the distutils folder 

I've tried using the mingw complier to install the distutils but i recieved an error saying that the library have been compiled using MVS 7.1 

any ideas what i can try next...

where could i get my hands on MVS 7.1

--- Robert Kern <robert.kern at gmail.com> wrote:

From: Robert Kern <robert.kern at gmail.com>
Date: Tue, 13 Dec 2005 00:55:18 -0800
To: msomers at mail.ie, SciPy Users List <scipy-user at scipy.net>
Subject: Re: [SciPy-user] scipy on XP isnt happening

Martin Somers wrote:
> Trying  to in stall a single plotting package for scipy and its
> not happening,  

scipy no longer distributes any plotting packages. Older versions (0.3.x) do
have some, but they are unsupported. Probably the best place for you to start
with is matplotlib.


> I must have some strange configuration as most
> my  efforts  under  XP  were fruitless, 
> trying to install chaco using  python  setup.py build python setup.py install I getting an  import error of no module names seup_agg (which seems to be part  of swig) 

Where did you get this version of Chaco? It is almost certainly not up-to-date.
A more current, working version of Chaco is coming soon, but it will not be a
part of scipy.

> The only other thing I can think of is that I’ve downloaded  Unix  files  and  trying  to  run  them…. 
> Surely an installation  can’t  be  that difficult, by the way I dont see a default  plotting package in scipy well those that I have tried wont  work  
> Any  ideas  on  how to get scipy out of its box and running  

We can't help you until you give us more detailed information like what version
of Python you have installed, what version of scipy you are trying to install,
what C and Fortran compilers you are using, and the actual text of the error
messages you are seeing.

> I also seem  to  be having a lot of trouble with the files
> housed in the distutils folder … what do they do 

They actually build and install the package.

Robert Kern
robert.kern at gmail.com

"In the fields of hell where the grass grows high
 Are the graves of dreams allowed to die."
  -- Richard Harter

Sign up for Private, FREE email from Mail.ie at http://www.mail.ie

More information about the SciPy-user mailing list