[SciPy-user] As requested, a the OSX install odyssey

Frank dalembertian at yahoo.com
Tue Dec 20 12:37:24 CST 2005

In response to Ed's request of me several days ago, this seems like a  
good time (recalling Felis' recent trouble with the scipy_core  
install on OSX) to relate my troubles with the scipy install on OSX.

Before I go on, I should say that I ultimately had no trouble  
installing from the newly updated instructions at Chris' site after I  
deleted the directory (thank you, Robert):


and used the gcc 3.3 compiler. Incidentally, according to the  
instructions, the latter step seems optional - it is not. I have  
never gotten anything close to a correct build with gcc 4. Also, I  
think the former step should be explicitly included in the  
instructions. Something to the effect of "if you screw it up, then  
delete this directory." That was a source of pain for me, I had  
figured (foolishly) that a new build from SVN would just "fix"  
whatever was wrong in that directory. Of course, it did not.

Building from SVN (from the OLDER OSX instructions) was painful and  
never fully worked. First, install Numeric, however, you see on the  
numpy sourceforge site a download of the scipy_core "Numeric  
replacement." That should be better, right? No, it doesn't install  
without distutils. Oh, there is no mention of those anywhere in the  
instructions. Back to installing Numeric. Oh, that doesn't work on  
Tiger without a modification to "customize.py." The readme claims  
that the installer will just "know" that it is an OSX system and thus  
"know" where the lapack  (vecLib) directories are. That did not work  
for me so it took me awhile to figure out how just to get Numeric  
going. No mention of such troubles on the site.

In the next step, I see (on the F2PY website, only) that F2PY  
requires scipy_distutils. The only link I ever found to get them was  
on the F2PY website. Ok, distutils and F2PY installed.

I then followed the CVS link (which linked to SVN instructions) and  
dutifully downloaded the core and started my build/install. For  
whatever reason (possibly a bad link from installing some piece along  
the way via gcc4?), that never worked and I had to download the full  
scipy from the link on the OSX  instruction site. Only after fighting  
through the many configuration changes (e.g., extra link args) was I  
able to get anything going.

The worst bit was (again, probably due to crap from broken installs  
stuck in my site_packages directory) that after the core claimed to  
install, the scipy build/install never finished without errors. The  
only way I got anything going was to go into the CORE directory (yes,  
I wrote core; yes, I know it was wrong to do) and cd into the scipy  
directory and build/install scipy from there. Of course, this is  
wrong but please let me point out two key bits:

1) the build/install of scipy the correct way never completed (always  
citing missing core and/or distutils components)

2) I have read on forums (and even the archives of this mailing list)  
that the numeric replacement core and the core downloadable tarball  
(linked on the instruction page) are different.

When I combined these bits, I arrived at "oh, they must have meant  
this" type of install of scipy. Viola! It actually worked! I tested  
out the only function I needed at the time linalg.eig() - success! Of  
course, this left me with the (now infamous?) installation without  
interpolate or integrate but a working linalg and fft.

I hope I don't sound unappreciative. SciPy is truly great and I look  
forward to supporting its further development via spreading the word  
and contributing when I can.

Sorry this message was so long, but hey, you (Ed) asked.


More information about the SciPy-user mailing list