[SciPy-user] scipy install on mac os x

Evan Monroig evan at monroig.net
Mon Dec 26 04:14:00 CST 2005


summary: almost successful install on Tiger, only
clapack/cblas/fftpack seem not to work properly

I have already installed scipy on my linux box, and now I am trying
also to use it on a Mac Os X Tiger. I followed the recent discussions
on the mailing list, and tried to use them and here is my experience.

1) I used the python2.4.1 mac installer from here

2) I used the python2.4 fix for Tiger

3) I changed my path so that /usr/local/bin appears before /usr/bin
(the objective being that launching "python" in the shell goes to
python2.4 and not python2.3)

4) I used the 4 installers provided by on http://trichech.us/mac

One possible concern is that they were built for python2.4.2 and not
python2.4.1 but I think this should not pose problems

5) I ran the tests in the command line:
EvanL:~ evanmonroig$ python
Python 2.4.1 (#2, Mar 31 2005, 00:05:10)
[GCC 3.3 20030304 (Apple Computer, Inc. build 1666)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> from scipy import *
>>> test()
Ran 1372 tests in 8.686s

FAILED (failures=11)

I put all details in the attached files, but to sum up the failures
are mostly due to:
a) clapack module is empty
b) cblas module is empty
c) fftpack gives wrong results

Any thoughts? Should I install the lapack and blas library by myself,
or are they already on my system (it is likely so because I previously
installed Octave)?


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: MACOS10.4 Scipy Test.txt
Url: http://www.scipy.net/pipermail/scipy-user/attachments/20051226/def6ae21/MACOS10.4ScipyTest-0001.txt

More information about the SciPy-user mailing list