[SciPy-user] Re: Enthought python

Ryan Krauss ryanfedora at comcast.net
Tue Jul 19 11:20:30 CDT 2005

Alright, we are getting close.  I added C:\Python23\scripts to the 
windows path and moved the dll there (I don't think it was already 
there),  and now tesk_vtk finishes correctly. 

I tried running this example script out of the online manual:
import mayavi
v = mayavi.mayavi() # create a MayaVi window.
d = v.open_vtk('test.vtk', config=0) # open the data file.
# The config option turns on/off showing a GUI control for the 
# load the filters.
f = v.load_filter('WarpScalar', config=0)
n = v.load_filter('PolyDataNormals', 0)
n.fil.SetFeatureAngle (45) # configure the normals.
# Load the necessary modules.
m = v.load_module('SurfaceMap', 0)
a = v.load_module('Axes', 0)
a.axes.SetCornerOffset(0.0) # configure the axes module.
o = v.load_module('Outline', 0)
v.Render() # Re-render the scene.

(Aftter running the preceding portion to generate the data.)

The visualization pops up but so does an error message that says:
ERROR: In C:\aap\src\VTK\Rendering\vtkWin32OpenGLRenderWindow.cxx, line 216
vtkWin32OpenGLRenderWindow (0x06592F70): wglMakeCurrent failed in 
MakeCurrent(), error: The requested resource is in use.

I was getting this same error last night at home.  I had installed 
EntoughtPython and the above example worked out of the box.  But as soon 
as I updated either Ipython or Matplotlib to the current versions, I 
started getting the above error.

Thanks again for your help Prabhu.  I think we are getting close.


Prabhu Ramachandran wrote:

>>>>>>"Ryan" == Ryan Krauss <ryanfedora at comcast.net> writes:
>    Ryan> I tried placing vtkRenderingPythonTkWidgets.dll in all of
>    Ryan> the places you mentioned with no success.
>    Ryan> I went into def vtkLoadPythonTkWidgets(interp): and
>    Ryan> specifically appended the pathlist with a location where I
>    Ryan> had the dll installed:
>    Ryan> pathlist.append('C:\\Python23\\Lib\\site-packages\\vtk_python\\vtk\\tk')
>Hmm, I replied in a hurry.  Is C:\\Python23\\Scripts in your PATH?  If
>it is not then that might be the cause.  For some reason this DLL has
>to be in your PATH.
>Alternatively, if C:\\Python23 is in your path, then put the dll there
>and test.
>I am not sure about why and how this happens since I've never had the
>chance to fully debug this.
>SciPy-user mailing list
>SciPy-user at scipy.net

More information about the SciPy-user mailing list