[SciPy-user] scipy for win32 and python2.4 - howto ...

Robert Kern rkern at ucsd.edu
Wed Jul 20 18:59:30 CDT 2005

Sebastian Haase wrote:
> Hi,
> I was ready to build scipy for windows with python2.4 ...
> I have got the (now free!) Microsoft compiler VC7. I have been using it for a 
> month or so on a couple of projects. I did the necessary tweaking for 
> distutil. 

What FORTRAN compiler do you intend to use?

> BUT:
>  1) before I can even start: "setup.py build" complains about many things nor 
> being available:  
>   1a) I think I can ignore fftw - for now ...
>   1b) I downloaded the ATLAS source - but that seems to be "tricky"  (seems to 
> be meant more for linux)  ==> I thought for the py24 build one should be able 
> to just reuse whatever was done for py23 - ATLAS and LAPACK and BLAS - 
> right ?     Can someone make those available ? 


>   1c) f2py ... is that available as binary ?

It is pure Python.

> 2) Really I'm mostly (only) in need of the plt module (for now).  Is there an 
> easier way in this  case ?

Possibly, but plt, gplt and xplt are deprecated. It is suggested that 
you use matplotlib instead.

Robert Kern
rkern at ucsd.edu

"In the fields of hell where the grass grows high
  Are the graves of dreams allowed to die."
   -- Richard Harter

More information about the SciPy-user mailing list