[SciPy-user] scipy test file error

Leila baghdadi baghdadi at sickkids.ca
Mon Mar 7 13:09:31 CST 2005

Hi Pearu,

I just thought I share this with the list in case anyone is also using

1) when I installed Numeric 23.5 and tried to run the test as you told

import scipy

it complained about wxpython and got a segfault (I saw it after I
e-mailed you yesterday)

2) after you told me that you have Numeric 23.1 on your opteron I
decided to get it just for a testing

so now I can run 

scipy.test() and there are no segmentation faults but there is a few
errors which I am hoping to fix,
a) it complains about a few test no being there from plt, I guess that
is because I have no wxpython

b)few tests fail with this message
Attribute Error : 'module' object has no attribute 'eig'

I have also attached a text file of the error message,

can you please give me a hint as in what to do and how to fix this

Thanks very much


On Sun, 2005-03-06 at 16:43, Pearu Peterson wrote:
> On Sun, 6 Mar 2005, Leila baghdadi wrote:
> > so I think what happened is I got Numeric 23.7 which was basically
> > creating the problem (not sure why),
> >
> > I was not sure what to do so I just got a previous version of Numeric
> >
> > 23.5 and installed that and BAM the problem is solved, so I am sure not
> > sure what the difference between 23.5 and 23.7 but the reshape and
> > resize functions were giving me problems on Opteron.
> In my Opteron box I have rather old Numeric, 23.1, and all tests succeed.
> When I get time to upgrade to 23.7, I'll look into this problem.
> > a quick question is do you need wxPython for running scipy.test()
> > because it is complaining
> >
> > /projects/mice/share/arch/linux64/lib/python2.2/site-packages/scipy/plt/interface.pyc No module named wxPython
> No, just without wxPython plt will not be functional.
> Pearu
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-user
-------------- next part --------------
A non-text attachment was scrubbed...
Name: my_stuff
Type: application/octet-stream
Size: 53698 bytes
Desc: not available
Url : http://www.scipy.net/pipermail/scipy-user/attachments/20050307/90f920bf/my_stuff-0001.obj

More information about the SciPy-user mailing list